Jump to content
Sign in to follow this  
woolywilly

Player owned store

Recommended Posts

When i try to search an item in player owned store, the chat box, is just plain. It doesnt allow me to search for any items. Its been doing it for a couple of days now. Ive tried closing my client, and reloading, amd ive also tried logging out obviously. I would really appreciate some help! Thank you :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

General Chat

General Chat

Please enter your display name

×
×
  • Create New...